CitroenChat.com - Singapore Citroen Community  

Go Back   CitroenChat.com - Singapore Citroen Community > Model Specific Discussions > C4

Reply
 
Thread Tools Display Modes
Old 08-01-2019, 09:13 PM   #1
blaze.boshev
Junior Member
 
Join Date: Jan 2019
Posts: 1
Default AL4 DPO automatic gearbox 4 speed

Hello, i have Citroen C4 coupe 2004 production 1.6 gasoline with automatic gearbox AL4 DPO 4 speed.. i have problem when i drive and when i slow the speed i hear something big "boom" like a crash gearbox, then the light for service is turned on and the display for showing who speed im drive didnt show the speed.. the car is lost the power.. when i parking and turn off engine and again turn on.. the car have the power the display is show my speed and service light is turned off.. i have change the oil in gearbox and filter.. but this problem still i have.. someone if know please help me

Sent from my SM-G935F using Tapatalk
blaze.boshev is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +8. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Citroenchat.com is not affiliated with CitroŽn or any other commercial company. "Citroen", its logos, and model names are registered trademarks of PSA.