CitroenChat.com - Singapore Citroen Community  

Go Back   CitroenChat.com - Singapore Citroen Community > Model Specific Discussions > C4 Picasso

Reply
 
Thread Tools Display Modes
Old 01-09-2015, 01:44 PM   #21
yap18
Connoisseur
 
yap18's Avatar
 
Join Date: Nov 2010
Location: Simei
Posts: 809
Default

Quote:
Originally Posted by dcll View Post
And I assume my Petrol version of C4GP has this Turbo function above the 1850rpm range as what CItC4 mentioned previously.
Previous C4gp turbo kick in much lower at 1400rpm...
__________________
Daewoo-Espero
Opel Zafira
Hyundai Trajet
C4GP
yap18 is offline   Reply With Quote
Old 03-08-2018, 07:13 PM   #22
echoy
Junior Member
 
Join Date: Aug 2018
Posts: 1
Default Fan on all time

Hi,

I have read this thread by the way, and I have a similar issue with my diesel Citroen DS5.
When the engine is off the fan is running and doesn't stop. The first time the battery went off and I had to recharge it.
I went to the garage workshop and they scanned it and didn't find anything, the problem disspeared before by the way but I went for checking anyway.
Now it is again with the same issue, and I have to unplugg the battery because it would go off otherwise.
Have some of you had a similar issue? What it can be?

Thanks in advance,
echoy is offline   Reply With Quote
Old 04-08-2018, 11:07 PM   #23
SkyC4
Connoisseur
 
SkyC4's Avatar
 
Join Date: Jul 2012
Posts: 872
Default

Quote:
Originally Posted by echoy View Post
Hi,

I have read this thread by the way, and I have a similar issue with my diesel Citroen DS5.
When the engine is off the fan is running and doesn't stop. The first time the battery went off and I had to recharge it.
I went to the garage workshop and they scanned it and didn't find anything, the problem disspeared before by the way but I went for checking anyway.
Now it is again with the same issue, and I have to unplugg the battery because it would go off otherwise.
Have some of you had a similar issue? What it can be?

Thanks in advance,
The radiator fan, the controller, the temperature sensor could all be at fault. Need to read fault code again to be sure.

Sent from my Redmi Note 4 using Tapatalk
SkyC4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +8. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Citroenchat.com is not affiliated with CitroŽn or any other commercial company. "Citroen", its logos, and model names are registered trademarks of PSA.