CitroenChat.com - Singapore Citroen Community  

Go Back   CitroenChat.com - Singapore Citroen Community > Model Specific Discussions > C4 Picasso

Reply
 
Thread Tools Display Modes
Old 17-04-2018, 09:48 AM   #1
wsngang
Member
 
Join Date: Sep 2014
Location: Geylang
Posts: 42
Default Just to share, fan spinning after engine down, and juddering while going up slope.

Hi All,

Just a sharing on my observation on the mysterious problem that have been haunting me for years despite checking by various workshops. For your reference if you are having the same issue as mine.

- I posted last year in this forum regards the fan should continue to blow for about 30 secs after engine off (most of the time), and some how, dunno since when, it does not blow anymore. NOT ONLY THIS, since many years, after COLD START, for the first 5 mins, I can always HEAR something in engine compartment is vibrating when RPM hit 3000. It will go away after a short while. Changing of the low speed fan solve this problem.

- I change my timing chain last week due to timing chain tensioner oil leak. However, it solve my another mysterious issue, when going up slope during traffic jam (for eg. the coast way between SG and MY woodlands custom), when you stop at slope and wanna move, there is always a few mild "jerks". Also get a few workshop to check and nothing found. Now, the problem has gone away after changing the timing chain. Not sure it is relevant or just coincidence. I was thinking maybe the chain is too loose and it slips when the engine try to move a car at a up slope.

Lastly, a disclaimer, I am not technical in car. Just feel glad when mysterious problem finally got resolved after years. Thanks for reading.

UPDATE : I am driving C4GP (petrol), registered on Nov 2010.
wsngang is offline   Reply With Quote
Old 17-04-2018, 10:26 AM   #2
vincenttanpt
Regular
 
Join Date: Dec 2010
Posts: 206
Default

Yes.

I used to have the 30 secs fan blowing after car switched off in the early years. My family members and petrol attendant always highlight to me I forgot to switch off my car. To which I always reply to them, this car is like that.

Somehow along the years I forget about that until the keep getting overheating alert in my car. It always shows top up coolant where my coolant is evidently must available.

I told Thomas I really suspect my fan need replacement. He did a diag and found it's running fine. In the end, he solve it by replacing my coolant sensor. The alert is gone but I always believe something not right. Based on the dashboard temp, my front tires TPMS will report at the bottom can be nearly 10-15 degrees hotter.

Of cos they insisted is like that. I even checked with Antz. They also never heard about the 30secs running after switch off too.

There's once I was in C&C and I talked to the service engineer at the counter, he sort of hinted during a firmware upgrade, this was turned off though he can't be certain.

Then I started google around, it appears there are reports in which the timer that do the auto-cutoff after 30 secs is not that reliable. Some owner cars will have the fan run until their batt ran out. So, I sort of believe the manufacturer has quietly turned off this.

After a few months later, I got a shock of my life when my front car start to see white smoke while driving. Thought my car going to explode. After stopped by, it turned out to be my coolant was boiling. Got it towed to Antz and they told me my fan gave way.

After replaced, I now always ensure my fan is running loudly (heard is high speed mode) when driving. And now, my TPMS tires temperature is always 2-5 degree higher. Even my daughter told her classmates to identify my car, just hear the loudest fan will do.
__________________
Regards

Vincent

/---------------------
2000 Nissan Pulsar
2003 Renault Kangoo
2005 Hyundai Matrix
2011 Citroen C4 Grand Picasso!
vincenttanpt is offline   Reply With Quote
Old 17-04-2018, 12:04 PM   #3
wsngang
Member
 
Join Date: Sep 2014
Location: Geylang
Posts: 42
Default

The fan issue seems interesting, I guess not much people experience that... No one (workshops) able to diagnose the cause until 1 fine day, the water coolant tank burst, which is where the white smoke came out drama... back then, I happens to be at Kaki Bukit area, so Antz suggest can try drive with extremely care and gentle to their workshop. A simple 400m distance took me about 40 mins. Need to stop and pull aside immediately whenever see the "STOP" sign and let the engine cool down for 15 mins. The MOST STRESSFUL ride that I have ever had.

Only then, Antz found out that the low speed fan fail to kick in intermittently, but that is not recorded in the diagnostic car computer... AND due to long term heat exposure, many parts in the engine compartment (dunno what tube, what housing, etc) turn "old" much faster, and need to replace also...

Like every other industry, new generation of mechanic rely VERY much on computer. I guess that cant be helped though.

Lessen learnt, just like cancer, dun under estimate any minor symptom, but many a time, it is also because the medical technology is not advance enough to diagnose it... That's why I think forum contribute much on experience sharing, and perhaps can help each other to save some money in long run.
wsngang is offline   Reply With Quote
Old 17-04-2018, 01:22 PM   #4
vincenttanpt
Regular
 
Join Date: Dec 2010
Posts: 206
Default

Oh.

For me just happened I was in car wash. After wash finish, my car can't start and move. The car wash guys have to push hard to my car out.

Some car motorist tried help just start also failed. Call Thomas got a grumpy attitude and not helping. Also can't find C&C number.

So ended I just call AAS for help. On spot they replaced batt and found my fuel pump failed. Give a bit knock to the pump to make it alive. Then ask me to drive to C&C direct liao.

So on spot sign 1 yr member with AAS. A couple of months down the road, alternator gone and the fan gone. Twice I also just call AA and send to Antz @ Kaki Bukit. All free.

I think AAS will have me for a long time. Btw, C&C towing also use AAS hotline.
__________________
Regards

Vincent

/---------------------
2000 Nissan Pulsar
2003 Renault Kangoo
2005 Hyundai Matrix
2011 Citroen C4 Grand Picasso!
vincenttanpt is offline   Reply With Quote
Old 17-04-2018, 05:37 PM   #5
CougarGTR
Member
 
Join Date: Dec 2017
Posts: 60
Default

Quote:
Originally Posted by wsngang View Post
Hi All,

Just a sharing on my observation on the mysterious problem that have been haunting me for years despite checking by various workshops. For your reference if you are having the same issue as mine.

- I posted last year in this forum regards the fan should continue to blow for about 30 secs after engine off (most of the time), and some how, dunno since when, it does not blow anymore. NOT ONLY THIS, since many years, after COLD START, for the first 5 mins, I can always HEAR something in engine compartment is vibrating when RPM hit 3000. It will go away after a short while. Changing of the low speed fan solve this problem.

- I change my timing chain last week due to timing chain tensioner oil leak. However, it solve my another mysterious issue, when going up slope during traffic jam (for eg. the coast way between SG and MY woodlands custom), when you stop at slope and wanna move, there is always a few mild "jerks". Also get a few workshop to check and nothing found. Now, the problem has gone away after changing the timing chain. Not sure it is relevant or just coincidence. I was thinking maybe the chain is too loose and it slips when the engine try to move a car at a up slope.

Lastly, a disclaimer, I am not technical in car. Just feel glad when mysterious problem finally got resolved after years. Thanks for reading.

UPDATE : I am driving C4GP (petrol), registered on Nov 2010.
Thanks for sharing!

Mine is also a Nov/10 GP. Can you share the details of the workshop and cost for changing the timing chain kit?

Thanks in advance!
CougarGTR is offline   Reply With Quote
Old 17-04-2018, 11:46 PM   #6
wsngang
Member
 
Join Date: Sep 2014
Location: Geylang
Posts: 42
Default

I did that at Antz. Price S$9xx.
wsngang is offline   Reply With Quote
Old 09-08-2018, 04:47 PM   #7
wangiles
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default

Quote:
Originally Posted by wsngang View Post
I did that at Antz. Price S$9xx.
Hi. Will this eliminate the jerkiness and knocking when driving up slope or the dragging of the gear when trying to speed up? 4AT user here.
wangiles is offline   Reply With Quote
Old 10-08-2018, 07:32 PM   #8
wsngang
Member
 
Join Date: Sep 2014
Location: Geylang
Posts: 42
Default

Oh ya, I forgot to further update. The slight jerk still happen, but much milder, when we are at steeper slope. The problem is completely resolve after I replace the clutch, which is totally worn. My mileage is around 16xK and that was the first clutch replacement. In fact, after replacing the clutch, you can feel that the car is so much more powerful, and no more "delay" and "jerk" when accelerating, especially at the slope.
wsngang is offline   Reply With Quote
Old 13-08-2018, 11:10 PM   #9
vincenttanpt
Regular
 
Join Date: Dec 2010
Posts: 206
Default

Quote:
Originally Posted by wsngang View Post
Oh ya, I forgot to further update. The slight jerk still happen, but much milder, when we are at steeper slope. The problem is completely resolve after I replace the clutch, which is totally worn. My mileage is around 16xK and that was the first clutch replacement. In fact, after replacing the clutch, you can feel that the car is so much more powerful, and no more "delay" and "jerk" when accelerating, especially at the slope.
I never had jerkness. Only rattles sound which Antz told me is my timing chain. Replaced after which is ok. Haven't replace clutch yet. I'm at 155k mileage.

Now only have low engine oil warning. Which I will just top up about 1.5L.

This week went JB. Kena a bump. Then all the circuit warning lights up. After restart all back to normal.

Sent from my ALP-L29 using Tapatalk
__________________
Regards

Vincent

/---------------------
2000 Nissan Pulsar
2003 Renault Kangoo
2005 Hyundai Matrix
2011 Citroen C4 Grand Picasso!
vincenttanpt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +8. The time now is 07:44 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Citroenchat.com is not affiliated with CitroŽn or any other commercial company. "Citroen", its logos, and model names are registered trademarks of PSA.